Virtual Box VM error – E_FAIL (0x80004005)

I’ve been working away on a dev.project with SharePoint 2010 and Visual Studio 2010 with a VM on my SSD – runs nice actually !

Yesterday, I was working on a client site, and so I’d been connecting to the internet using my wireless broadband (3G) USB stick – was fine for email and such – but couldn’t get the VM to connect over the 3G, even though it was set to use it.

image

At the end of the day (yesterday), I did a “Save State” on the VM.

image

…and then shut down Windows 7 (main o/s), which did a few updates – and then I headed off home.

This morning – when on the train – I went to fire up my VM – and got THIS error :

image

Failed to open a session for the virtual machine SPR (SSD).  The VM session was closed before any attempt to power it on.

Result Code : E_FAIL (0x80004005)

Component : Machine

Interface : ISession {GUID}

Oh no !   My code hasn’t been checked in – no, no, nooooo !!

I remembered that Windows 7 (host o/s) had done some updates, perhaps one of those caused the problem !?

THEN – I noticed something in the settings page – and had a ‘hunch’ what it might be.

image

Also – the error related to “Machine” and “Interface”.

Sure enough – once I’d popped in the wireless 3G USB stick – and tried to crank up the VM, I got a different error.  

image

In that circumstance, I hadn’t waited long enough – and the driver wasn’t detected/installed (yet).   So, I waited 20 seconds – and re-tried – didn’t actually need to connect to the internet – and the VM fired up successfully !

I guess the VM couldn’t ‘restore’ without all the devices that it had been saved with.

I quickly changed the Network setting to “WiFi” – it will ‘work’, just might not have a connection.

So – if you get that error – make sure you have the correct peripherals – esp. with regard to NETWORK devices.

Hope that helps you avoid the heart attack, like I almost had !!

Smile

Advertisements

One thought on “Virtual Box VM error – E_FAIL (0x80004005)

  1. In my case, I could not go back to saved machine state (I had uninstalled guest additions from virtual box’s CD/DVD after shutting down virtual box with saved state with guesadditions). But, what worked for me is , I removed CD/DVD from the boot order and started the machine again. It booted!!!

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s